Request to GitHub web hook has been made from prohibited IP address

Jens Schulze's Avatar

Jens Schulze

24 Apr, 2019 09:47 AM

In our Github project is a webhook setup to trigger an AppVeyor build, but the events sent to the webhook are always returning 403 since today.

  1. 1 Posted by Filip Krane Ada... on 24 Apr, 2019 09:51 AM

    Filip Krane Adamsen's Avatar

    We are also experiencing this.

  2. 2 Posted by Till WOlff on 24 Apr, 2019 09:55 AM

    Till WOlff's Avatar

    Same problem here! :)

  3. 3 Posted by Hielke on 24 Apr, 2019 09:57 AM

    Hielke's Avatar

    We're also experiancing this issue.

    Error first occurred on 11:08 (UTC+1)
    Still worked fine on 10:59.

    Status code: 403.
    Body: {"message":"Request to GitHub web hook has been made from prohibited IP address."}

  4. 4 Posted by Raising IT Deve... on 24 Apr, 2019 10:12 AM

    Raising IT Development Team's Avatar

    We are also seeing this with all of our builds.

  5. 5 Posted by greg on 24 Apr, 2019 10:24 AM

    greg's Avatar

    Just another voice raising this as an issue

  6. 6 Posted by Andi on 24 Apr, 2019 10:27 AM

    Andi's Avatar

    Hello? Is someone looking? https://status.appveyor.com/ is still not showing anything and no builds are working anymore

  7. 7 Posted by nazmialtun88 on 24 Apr, 2019 10:29 AM

    nazmialtun88's Avatar

    Hoping this issue will be fixed soon.

  8. 8 Posted by Alexandru Puiu on 24 Apr, 2019 10:36 AM

    Alexandru Puiu's Avatar

    We are also having this issue when sending from GitHub to Appveyor webhook:
    Response Headers:
    Cache-Control: no-cache
    Content-Length: 82
    Content-Type: application/json; charset=utf-8
    Date: Wed, 24 Apr 2019 10:31:48 GMT
    Expires: -1
    Pragma: no-cache
    Strict-Transport-Security: max-age=31536000
    X-Content-Type-Options: nosniff
    X-Frame-Options: SAMEORIGIN
    X-XSS-Protection: 1; mode=block
    Body
    {"message":"Request to GitHub web hook has been made from prohibited IP address."}

  9. 9 Posted by pietroalbini on 24 Apr, 2019 11:04 AM

    pietroalbini's Avatar

    This is also affecting rust-lang/rust's CI.

    Pietro.

  10. 10 Posted by Raising IT Deve... on 24 Apr, 2019 11:04 AM

    Raising IT Development Team's Avatar

    Issue has been happening for over an hour, and status page is still showing green.

  11. 11 Posted by matt on 24 Apr, 2019 11:09 AM

    matt's Avatar

    We are also suffering from this problem, hope someone can rectify soon?

  12. 12 Posted by Jens Schulze on 24 Apr, 2019 11:14 AM

    Jens Schulze's Avatar

    The build system itself is working. The Webhook maybe also. Only the IP range from github seems to have been blacklisted. So the status page is not directly lying.

    And as it's 4:13 AM in Vancouver I'm pretty sure that there are no office hours atm. ;)

  13. 13 Posted by filipe on 24 Apr, 2019 11:25 AM

    filipe's Avatar

    We're having this problem too.

  14. 14 Posted by Tamas on 24 Apr, 2019 11:29 AM

    Tamas's Avatar

    We have the same issue

    {"message":"Request to GitHub web hook has been made from prohibited IP address."}

    Is there an ETA for the fix already?

  15. 15 Posted by Patrick on 24 Apr, 2019 12:09 PM

    Patrick's Avatar

    Same! Fix please!

  16. 16 Posted by Dan on 24 Apr, 2019 12:27 PM

    Dan's Avatar

    Same problem here.

    At 2019-04-24 11:21:59 +0300 the webhook ran ok
    Starting with 2019-04-24 12:10:02 +0300 all webhooks fail with 403

    {"message":"Request to GitHub web hook has been made from prohibited IP address."}
    
  17. 17 Posted by Chris Nevett on 24 Apr, 2019 12:43 PM

    Chris Nevett's Avatar

    At least now we know not to trust the status page

  18. 18 Posted by Chris Taylor on 24 Apr, 2019 12:55 PM

    Chris Taylor's Avatar

    Really poor show from AppVeyor here. No response to this discussion, support email or twitter message.

  19. 19 Posted by Stewart on 24 Apr, 2019 01:10 PM

    Stewart's Avatar

    I've never noticed their status page accurately reflect an actual issue - always displays everything working....
    It's pointless

  20. Support Staff 20 Posted by Feodor Fitsner on 24 Apr, 2019 01:34 PM

    Feodor Fitsner's Avatar

    Hi guys,

    The issue has been resolved: https://status.appveyor.com/incidents/378v468f35qq

    We sincerely apologize for the inconveniences caused by this issue!

  21. 21 Posted by Robert on 24 Apr, 2019 01:47 PM

    Robert's Avatar

    With respect, is there a reason that this was not handled 2 weeks ago when GitHub announced the upcoming change? I know stuff falls through cracks, but it seems like this shouldn't be one of them given it takes down the entire chain.

  22. Support Staff 22 Posted by Feodor Fitsner on 24 Apr, 2019 01:50 PM

    Feodor Fitsner's Avatar

    Must be missed the announcement! Could you drop a link to it please?

  23. 23 Posted by Robert on 24 Apr, 2019 01:54 PM

    Robert's Avatar
  24. Support Staff 24 Posted by Feodor Fitsner on 24 Apr, 2019 01:55 PM

    Feodor Fitsner's Avatar

    Thank you!

  25. 25 Posted by michael on 24 Apr, 2019 02:04 PM

    michael's Avatar

    I find a response time of under 4 hours (5:47 am to 9:30 am) to be pretty amazing.
    Thank you Feodor for the quick fix.

  26. Ilya Finkelshteyn closed this discussion on 24 Apr, 2019 02:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac