Pro 4-cores subscriber but "docker-switch-linux" recently not working (again)

Bob Jordan's Avatar

Bob Jordan

30 Apr, 2019 07:49 AM

My builds are failing again same as they have before - because the "docker-switch-linux" command is not working. When it doesn't work, as indicated by "No activity detected on VM, aborting" message, my tests fail.

Below is a link to a build :
https://ci.appveyor.com/project/bmjjr/transistor/builds/24196272

Frankly, I feel like I pay too much money for the 4-cores version, for this to ultimately be so unreliable. I don't build so often, but I expect it should work when I do need it. What is causing this recurring problem on your end?

Thanks,
Bob

  1. Support Staff 1 Posted by Ilya Finkelshte... on 30 Apr, 2019 03:03 PM

    Ilya Finkelshteyn's Avatar

    Hi Bob,

    Sorry for the hustle. Docker for Windows keeps failing when we apply Windows updates to the Hyper-V host machines and VMs on Windows Server 2016. That's why we decided to discontinue it's support on Visual Studio 2017 image (which uses Windows Server 2016). We updated customers who use it directly over email and it seems that we missed you. Sorry for that.

    We introduced new Azure VM based Windows Server 2019 image specifically for those cases. Please check usage sample here. It is basically the same, just shared drive is now D:, not X:.

    Windows Server 2019 image is enabled for you, please give it a try. Note that build start time will be 3-4 minutes (time to provision a VM on Azure).

    With your current plan VMs of Standard_D4s_v3 size will be instantiated for you on Azure when you choose Windows Server 2019 image. If you have only public repos, you can switch to the free plan and still use this feature, but with VMs of Standard_D2s_v3 size.

    Ilya.

  2. 2 Posted by bob on 07 May, 2019 02:35 AM

    bob's Avatar

    Hi llya,

    Thanks for the update. Want to let you know that now the build is getting stuck on installing rabbitmq. Perhaps erlang is not installed on this image? I'm working on troubleshooting to find out but it would be better if it worked like it did before.

    D:\host\transistor\appveyor\rabbitmq.ps1
    Installing RabbitMQ...
    Downloading...
    Installing...
    
  3. 3 Posted by bob on 07 May, 2019 03:36 AM

    bob's Avatar

    Confirming, installing erlang is required on this image. Would be great if it could be pre-installed. Thank you.

  4. Support Staff 4 Posted by Ilya Finkelshte... on 07 May, 2019 07:44 AM

    Ilya Finkelshteyn's Avatar

    Will do. Can you try using this script at install stage to unblock yourself now?

  5. Support Staff 5 Posted by Ilya Finkelshte... on 10 May, 2019 09:28 PM

    Ilya Finkelshteyn's Avatar

    Please watch this issue.

  6. Support Staff 6 Posted by Ilya Finkelshte... on 16 May, 2019 02:54 AM

    Ilya Finkelshteyn's Avatar

    We deployed updated image which contains Erlang 9.2

  7. Ilya Finkelshteyn closed this discussion on 16 May, 2019 02:54 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac