ubuntu1804 update issue

daniel.hrisca's Avatar

daniel.hrisca

27 Jun, 2019 06:17 AM

Hello,

I was getting this error

https://ci.appveyor.com/project/danielhrisca/asammdf/builds/25557631/job/c1fgcr1iwmjtnwh4

which made me add "sudo apt --yes update" to the appveyor.yml . Now the packages are found but I'm getting this inteactive prompt:

https://ci.appveyor.com/project/danielhrisca/asammdf/builds/25576556/job/fkynurba0j4tg9su

How can I bypass it to continue the job?

  1. 1 Posted by ianfhunter on 27 Jun, 2019 11:17 AM

    ianfhunter's Avatar

    I am also experiencing this issue with the same package

  2. 2 Posted by Owen McDonnell on 29 Jun, 2019 02:13 PM

    Owen McDonnell's Avatar

    I forked your repo and tried for some time to perform a truly unattended platform update, with no success.
    Is this something you are able to do on your local ubuntu machine?

  3. 3 Posted by Martin F on 04 Jul, 2019 09:44 AM

    Martin F's Avatar

    Any updates on this issue? Would be great to resolve

  4. 4 Posted by daniel.hrisca on 04 Jul, 2019 09:54 AM

    daniel.hrisca's Avatar

    I did not have such an issue running locally.

    Any way you could update the ubuntu1804 image?

  5. Support Staff 5 Posted by Feodor Fitsner on 04 Jul, 2019 05:29 PM

    Feodor Fitsner's Avatar

    Hi Daniel,

    We are looking into that, thanks for your patience!

  6. Support Staff 6 Posted by Wasa Pleshakov on 04 Jul, 2019 06:05 PM

    Wasa Pleshakov's Avatar

    Hi Daniel,
    This happens from time to time. You may set DEBIAN_FRONTEND=noninteractive prior running apt-get:

    sudo DEBIAN_FRONTEND=noninteractive  apt-get --yes update
    
  7. 7 Posted by ianfhunter on 04 Jul, 2019 07:35 PM

    ianfhunter's Avatar

    I've already tried this fix and still experiencing this issue

    https://ci.appveyor.com/project/ianfhunter/dice#L260

  8. Support Staff 8 Posted by Wasa Pleshakov on 06 Jul, 2019 07:56 AM

    Wasa Pleshakov's Avatar

    Ian,
    In your build I see that error appears when you install python3-pip package.
    You may add variable there:
    sudo DEBIAN_FRONTEND=noninteractive apt-get install -y python3-pip Furthermore, I checked all variables set in the environment and it turns out that DEBIAN_FRONTEND is already set. But it has to be passed by sudo to apt-get. One can do it with -E option:
    sudo -E apt-get install -y python3-pip

  9. 9 Posted by ianfhunter on 06 Jul, 2019 08:14 AM

    ianfhunter's Avatar

    Thanks Wasa, I can confirm that fixed it for me. Seems like all the documentation out there was just describing the fix for the apt update.

    Many thanks.

  10. 10 Posted by daniel.hrisca on 08 Jul, 2019 09:48 AM

    daniel.hrisca's Avatar

    Hello Wasa,

    I can confirm that the fix works for my project as well (https://ci.appveyor.com/project/danielhrisca/asammdf/builds/25815133) . Thank you!

  11. Wasa Pleshakov closed this discussion on 08 Jul, 2019 06:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac