Deploy stage not running

James Anderson's Avatar

James Anderson

10 Sep, 2019 08:49 AM


I can't get my build to deploy to my Octopus server. No errors are raised it just doesn't push the packages. I have other builds that push fine. They have a build phase and this build has a build_script phase. I have a feeling that's the issue but I've tried following the docs and I can't get it to push. My appveyor.yml is below:

version: "{build}"

clone_folder: C:\Projects\my_project

  - mssql2016

image: Visual Studio 2017

  account_feed: true

platform: Any CPU
configuration: Release

    secure: MyKey

    - master
    - develop
    - release
    - feature
    - bugfix
    - hotfix

  - C:\Python37\Scripts\pip.exe install -r requirements.txt -q

  - C:\Python37\Python.exe -m PyInstaller source\ --onefile --hiddenimport pyodbc --hiddenimport pymssql --hiddenimport sqlalchemy.ext.baked

  - ps: mkdir packages
  - ps: octo pack --id=my_company.my_project --version="0.1.30" --basePath="$env:APPVEYOR_BUILD_FOLDER\dist\" --outFolder="$env:APPVEYOR_BUILD_FOLDER\packages\"

  - path: \packages\*.nupkg
    name: my_project
    type: OctopusPackage

  - provider: Octopus
    artifact: my_project
    push_packages: true
    create_release: true
    create_release_advanced: --releaseNumber="0.1.30" --packageversion="0.1.30"
    project: "Transfer Benefit"
    environment: Prod
    api_key: $(octoKey)
    push_packages_advanced: --ignoreSslErrors

  1. 1 Posted by James Anderson on 11 Sep, 2019 02:19 PM

    James Anderson's Avatar

    Can anyone help with this?

  2. 2 Posted by Owen McDonnell on 11 Sep, 2019 09:22 PM

    Owen McDonnell's Avatar

    Can you please link to the build.

  3. 3 Posted by James Anderson on 16 Sep, 2019 07:47 AM

    James Anderson's Avatar
  4. 4 Posted by Owen McDonnell on 16 Sep, 2019 06:19 PM

    Owen McDonnell's Avatar

    Can you try omitting the artifact: key from the deploy: settings and let us know the result.

  5. 5 Posted by James Anderson on 20 Sep, 2019 11:23 AM

    James Anderson's Avatar


    My comments are not getting approved. That didn't make any difference to build. Still didn't push the package. Anything else we can try?

  6. 6 Posted by Owen McDonnell on 20 Sep, 2019 03:19 PM

    Owen McDonnell's Avatar

    Can you link to a build that had this change but still did not push the package.

  7. 7 Posted by James Anderson on 23 Sep, 2019 08:24 AM

    James Anderson's Avatar
  8. 8 Posted by Owen McDonnell on 23 Sep, 2019 08:46 PM

    Owen McDonnell's Avatar

    The last link is for project's latest build. Specific build would have a build id in the url.

    Are you sure that your yml config file is the same across all branches? I'm asking because it looks like some of your builds happen on different build images. Does this behaviour of failing to push the octopus package happen on all branches?

  9. 9 Posted by James Anderson on 25 Sep, 2019 07:52 AM

    James Anderson's Avatar

    Cool, my two previous responses have not made it through moderation so I guess that's another day to wait if this one gets through. This is terrible.

    It's only in this branch that I am trying to push to Octopus. The appveyor.yml in this branch has not been merged to the other branches yet.

  10. Support Staff 10 Posted by Feodor Fitsner on 25 Sep, 2019 02:30 PM

    Feodor Fitsner's Avatar

    Hi James,

    It's Feodor here. Could you please drop a link to the specific build which was run with appveyor.yml without artifact: setting? The URL should end with ../build/<some_number>.

    Btw, your messages are reaching us without any issues or moderation. If you feel uncomfortable to use this support ticketing system you can email us at [email blocked].

  11. 11 Posted by James Anderson on 26 Sep, 2019 12:40 PM

    James Anderson's Avatar
  12. Support Staff 12 Posted by Feodor Fitsner on 26 Sep, 2019 11:33 PM

    Feodor Fitsner's Avatar

    That build is PR build therefore deployment was skipped. Deployment phase is not being run in PR builds unless explicitly allowed on project settings (General tab -> Enable deployments in Pull Requests). Let me know how that worked and sorry the resolution took so long.

  13. 13 Posted by James Anderson on 27 Sep, 2019 10:56 AM

    James Anderson's Avatar

    Thank you. I'm now pushing packages. Wooooooooo

  14. Support Staff 14 Posted by Feodor Fitsner on 27 Sep, 2019 02:13 PM

    Feodor Fitsner's Avatar

    No worries, thanks for the update!

  15. Feodor Fitsner closed this discussion on 27 Sep, 2019 02:13 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac