Cannot use PG12 service in Windows Server 2019 image

Ruslan Fomkin's Avatar

Ruslan Fomkin

08 May, 2020 08:03 AM

My appveyor.yml contains:
```yml image: Windows Server 2019
services:
- postgresql12 - docker

And PostgreSQL 12 is selected as a service in the GUI. However, I get:
Starting PostgreSQL 12
6Start-Service : Cannot find any service with service name 'postgresql-x64-12'.
7At line:1 char:1
8+ Start-Service 'postgresql-x64-12'
9+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
10 + CategoryInfo : ObjectNotFound: (postgresql-x64-12:String) [Start-Service], ServiceCommandException
11 + FullyQualifiedErrorId : NoServiceFoundForGivenName,Microsoft.PowerShell.Commands.StartServiceCommand
I guess PostgreSQL 12 is missing in Windows Server 2019 image. Can you fix it or can you clarify what I am missing?
Also reported in https://github.com/appveyor/ci/issues/3418
  1. Support Staff 1 Posted by Feodor Fitsner on 08 May, 2020 03:59 PM

    Feodor Fitsner's Avatar

    Windows Server 2019 image does not have PGSQL. It contains bare minimum + Docker.

    Use Visual Studio 2019 image instead which has PGSQL 9, 10, 11 and 12 (https://www.appveyor.com/docs/windows-images-software/#databases).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac