BYOC Init script ?

me's Avatar

me

19 May, 2020 02:26 PM

Hi,

Thank to your support I was able to create GCE instances to build.
Now when I try to build, they fail at the init step..
I have changed to following settings:

Environnment:
- Build cloud
- Build worker image

Build
- Platform

And you can see the build here but just in case i have pasted the logs
https://ci.appveyor.com/project/kittikun/ninniku/builds/32979963

Console:
Build started
Running "init" scripts
Value cannot be null. (Parameter 'script.script')

Events:

2020-05-19 23:14:15.709WarningJob has already completed
2020-05-19 23:14:12.817InformationDecommissioning worker: 3cc37d6edfdf425fbed8761a86c102a4
2020-05-19 23:14:12.732ErrorJob has failed
2020-05-19 23:14:12.732InformationDecommission worker in cloud 927: 3cc37d6edfdf425fbed8761a86c102a4
2020-05-19 23:14:11.091InformationJob has started
2020-05-19 23:13:15.299InformationCheck worker status in 60 seconds
2020-05-19 23:13:14.705InformationProvisioning worker of type 'GCE': 3cc37d6edfdf425fbed8761a86c102a4
2020-05-19 23:13:14.610InformationProvision worker in cloud 927: 3cc37d6edfdf425fbed8761a86c102a4
2020-05-19 23:13:14.579WarningBuild cache is not configured for the job
2020-05-19 23:13:14.579InformationBuild cache configured on cloud level:
2020-05-19 23:13:14.579InformationArtifact storage configured on system level: azure-artifacts-westus
2020-05-19 23:13:14.579InformationArtifact storage configured on cloud level:
2020-05-19 23:13:14.579InformationJob scheduled to cloud 927
2020-05-19 23:13:14.563InformationFetching clouds with name/group 'GCE asia-northeast1-a n1-highcpu-16' for account 26364
2020-05-19 23:13:14.563InformationImage found: Windows GCE (1667)
2020-05-19 23:13:14.563InformationStarted scheduling job
Account queue: 2 job(s)

I don't remember having to setup init scripts with the conventional Appveyor build ?

Thank you

  1. Support Staff 1 Posted by Feodor Fitsner on 19 May, 2020 06:19 PM

    Feodor Fitsner's Avatar

    OK, could you please try re-doing VM image with a newer Build Agent? We've just bumped its version to 7.0.2883: https://github.com/appveyor/build-images/commit/0df0b596d80d0d17ed4...

    Hope that helps.

  2. 2 Posted by me on 20 May, 2020 04:19 AM

    me's Avatar

    https://ci.appveyor.com/project/kittikun/ninniku/builds/32994915

    The build still fails but with less information.
    I guess I will just wait for you to add Windows 10 SDK (10.0.19041.0) instead of trying to use BYOC :)

  3. 3 Posted by me on 20 May, 2020 03:40 PM

    me's Avatar

    I have created a custom image to address this issue.
    Guess I will keep relying on your VMs!

    Closing this thread

  4. me closed this discussion on 20 May, 2020 03:40 PM.

  5. me re-opened this discussion on 20 May, 2020 06:41 PM

  6. 4 Posted by me on 20 May, 2020 06:42 PM

    me's Avatar

    Sorry, tried to create a custom image but apparently I cannot..
    I tried using APPVEYOR_BAKE_IMAGE and the image was created but I couldn't select it.
    I believe this option is not free and not available in my region (Japan) so I am back to this question..

    Sorry for the confusion!

  7. 5 Posted by me on 21 May, 2020 05:38 AM

    me's Avatar

    Tried once more with a new instance from scratch, same problems:
    https://ci.appveyor.com/project/kittikun/ninniku/build/job/k11g3nu66wx3h1h9/events

  8. 6 Posted by me on 21 May, 2020 09:49 AM

    me's Avatar

    Tried again with a brand new project scaling down and it properly managed to allocate disks (2) and instances (2) but same error

    Build started
    Running "init" scripts
    Value cannot be null. (Parameter 'script.script')

    https://ci.appveyor.com/project/kittikun/ninniku/build/job/655bqgvv959soulc

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac