GitHub deployment

Tim Jones's Avatar

Tim Jones

07 Sep, 2015 04:45 PM

I'm trying to create a GitHub release using AppVeyor, but every time I try I get a "422: Unprocessable entity" error. I'm doing this:

* Create a git tag locally
* Push tag to GitHub, which triggers an AppVeyor build
* AppVeyor is configured to create a GitHub release, using the same tag name

I thought, based on the AppVeyor GitHub docs, that this should be possible.

I wondered AppVeyor is trying to create a new release, which doesn't work because GitHub automatically creates a release for each tag, but I don't think that's it, because I still get the 422 even when I delete the git tag on GitHub and restart the AppVeyor build.

Here's my appveyor.yml:
https://github.com/tgjones/dryrunner/blob/master/appveyor.yml

  1. 1 Posted by Tim Jones on 07 Sep, 2015 04:46 PM

    Tim Jones's Avatar

    Forgot to mention: here's the project:
    https://ci.appveyor.com/project/tgjones/dryrunner

    Thanks in advance for any help you can offer!

  2. Support Staff 2 Posted by Feodor Fitsner on 07 Sep, 2015 05:51 PM

    Feodor Fitsner's Avatar

    Interesting. There was another similar report today. Maybe something has changed on GitHub side.

    Could you try creating the release using GitHub API from Postman or Fiddler.

    POST https://api.github.com/repos/tgjones/dryrunner/releases
    
    Content-Type: application/json
    Authorization: token <your-oauth-token>
    
    {
      "tag_name": "v0.2.1",
      "target_commitish": "88ff8bfb8ffd1ff72f2429a946ab1567e0539bd9",
      "name": "v0.2.1",
      "draft": false,
      "prerelease": false
    }
    
  3. 3 Posted by Tim Jones on 08 Sep, 2015 01:28 AM

    Tim Jones's Avatar

    Oops, my bad. I had messed up the permissions on the GitHub personal access
    token. Once I checked "public_repo", everything works fine. Sorry to waste
    your time.

  4. Support Staff 4 Posted by Feodor Fitsner on 08 Sep, 2015 02:05 AM

    Feodor Fitsner's Avatar

    No problem, thanks for the update!

  5. 5 Posted by egoroff on 11 Sep, 2015 06:39 PM

    egoroff's Avatar

    i still have the problem like this: Creating "v1.6.462.0" release for repository "aegoroff/logviewer" tag "v1.6.462.0" commit "cf45cf49798d5643b5ec35e401710a1bef2c7228"...Error creating GitHub release: Response status code does not indicate success: 422 (Unprocessable Entity).

    I tried to check permissions and the are OK but the problem is still here :(

  6. Support Staff 6 Posted by Feodor Fitsner on 11 Sep, 2015 06:40 PM

    Feodor Fitsner's Avatar
  7. 7 Posted by egoroff on 11 Sep, 2015 06:44 PM

    egoroff's Avatar

    After setting description i get this problem (as described here http://help.appveyor.com/discussions/problems/2975-github-deployment):

    Creating "v1.6.462.0" release for repository "aegoroff/logviewer" tag "v1.6.462.0" commit "cf45cf49798d5643b5ec35e401710a1bef2c7228"...OK
    Uploading "logviewer.install.1.6.462.0.exe" to release assets...Error uploading release asset: 400 - Bad Request

  8. Support Staff 8 Posted by Feodor Fitsner on 11 Sep, 2015 06:45 PM

    Feodor Fitsner's Avatar

    Will take a look. Maybe something has been changed in GH API, again.

  9. 9 Posted by egoroff on 11 Sep, 2015 06:46 PM

    egoroff's Avatar

    thank you :)

  10. Support Staff 10 Posted by Feodor Fitsner on 12 Sep, 2015 12:03 AM

    Feodor Fitsner's Avatar

    Found the issue. GitHub API has changed slightly - it returns upload URL in a different format.

    We'll deploy AppVeyor update with a fix later this week.

  11. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac