Can't deploy via FTP because of error message 450

Stephan Arenswald's Avatar

Stephan Arenswald

09 Oct, 2015 07:15 AM


I have set up artifacts and deployment to FTP. After the build finishes I have my artifacts listed and deployment starts. However, the FTP deployment returns the following message: "The remote server returned an error: (450) File unavailable" when trying to create the output folder on the target FTP site. I already checked that creating a directory on the FTP site works via different FTP clients.

Packaging artifacts...OK
Uploading artifact Brainchest.TimeStamp.WP8\bin\ARM\Release Pro\Brainchest.TimeStamp.WP8.xap (3.6 MB)...OK
Deploying using FTP provider
Uploading artifact "Brainchest.TimeStamp.WP8/bin/ARM/Release Pro/Brainchest.TimeStamp.WP8.xap" to FTP server "" as "Brainchest.TimeStamp.WP8/bin/ARM/Release Pro/Brainchest.TimeStamp.WP8.xap"
Creating remote directory "Brainchest.TimeStamp.WP8/bin/ARM/Release Pro"...The remote server returned an error: (450) File unavailable (e.g., file busy).

Do you have more detailed information on what's wrong here? Can I choose a target directory myself?

Regards, Stephan

  1. Support Staff 1 Posted by Feodor Fitsner on 09 Oct, 2015 05:34 PM

    Feodor Fitsner's Avatar

    Hi Stephan,

    There is a setting at the bottom of FTP provider settings form: Use alternative FTP library (beta). Enabled it together with Write FTP commands to console. Hope that helps.

  2. 2 Posted by Stephan Arenswa... on 12 Oct, 2015 11:01 AM

    Stephan Arenswald's Avatar

    This actually works fine now. Thanks for the help. You can close this discussion now.

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac