macOS build hangs

mouzedrift's Avatar

mouzedrift

10 Jan, 2023 07:35 PM

i'm trying to get the macOS build working but there is a problem with the build which causes the CI to hang during the build process until the timeout gets hit. i have tried all available macOS images and the issue persists. i thought maybe it ran out of memory and tried things like using make -j1 (hangs earlier) and make -j4 (hangs later). i also tried sudo purge to see if it might help but it didn't change anything.

build log: https://ci.appveyor.com/project/mouzedrift/alive-reversing/builds/4...
the repo i'm trying to build: https://github.com/mouzedrift/alive_reversing/tree/ci

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Jan, 2023 05:06 AM

    Feodor Fitsner's Avatar

    I honestly don't have an idea why that build hangs, but you may try connecting running VM via VNC and see around what's going on during the build: https://www.appveyor.com/docs/how-to/vnc-to-build-worker/?

  2. 2 Posted by mouzedrift on 11 Jan, 2023 04:56 PM

    mouzedrift's Avatar

    it appears that the cmake gui opened during the build because we used ${CMAKE} instead of ${CMAKE_COMMAND}. it no longer hangs after changing it. thanks for the help.

  3. mouzedrift closed this discussion on 11 Jan, 2023 04:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

27 Jan, 2023 08:06 PM
27 Jan, 2023 08:05 PM
25 Jan, 2023 03:23 PM
25 Jan, 2023 03:22 PM
23 Jan, 2023 03:29 PM