HostAgent on Remote Process (Windows 11) won't run successfully

anothergithubuser's Avatar


14 Apr, 2024 12:50 PM


my custom cloud 'MAINFRAME' shows as 'Active' in build environments. also getting 'Host Agent connection is alive' every minute in my eventlog.
upon starting a build, i get:

Assign job '0dbb9xrcc64mpdof' to cloud 3
Trying to assign job 0dbb9xrcc64mpdof to cloud 3.
Set status: Reserved
Updating cloud availability (buildCloudId=3): 19 worker(s) available, 1 worker(s) busy
Job 0dbb9xrcc64mpdof assigned to[worker-3-001] Received job message: JobId=0dbb9xrcc64mpdof, JobName=AppVeyor/projectname/1.0.5, JobTimeout=60, ImageName=Windows worker
Create build 'bin' directory: C:\Users\appveyor\AppData\Local\Temp\av-build-5
ERROR: [worker-3-001] Error starting Build Agent process: Build agent executable was not found
Set status: Recreate
[worker-3-001] Terminate worker process
i guess "C:\Program Files\AppVeyor\HostAgent\appveyor-build-agent.exe" is the correct path where it got installed.
i tried adding this path to the global environment PATH and to the local PATH for user appveyor. still same error gets produced.
the AuthorizationToken registry entry matches the Host agent authorization token in build cloud settings.
i also tried deleting "C:\ProgramData\AppVeyor\HostAgent\host-agent.db" and restarting the service AppVeyor Host Agent. same error.

AppVeyor version 7.0.3212, running on Ubuntu 22.04.4 LTS
HostAgent service running on Windows 11 Pro Version 23H2 (Build 22631.3447)

any help would be greatly appreciated!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac