Use Nuget 3.3

kneumei's Avatar

kneumei

13 Apr, 2016 06:04 PM

I guess with a recent change, nuget version is now 3.4. There seems to be some problem using nuget pack with this version (octopus deploy is not correctly extrtacting files created now with nuget pack with 3.4). What's the easiest way to revert back to using 3.3? I was thinking about doing cinst nuget.commandline, but having trouble finding where nuget is being installed.

  1. Support Staff 1 Posted by Feodor Fitsner on 13 Apr, 2016 06:15 PM

    Feodor Fitsner's Avatar

    I'm sorry to hear that change has broken your builds. As nuget 3.4 is a part of Visual Studio 2015 Update 2 I was sure its command-line counterpart is ready for production too.

    I did a script installing nuget 3.3. Add this to your appveyor.yml:

    install:
    - ps: iex ((new-object net.webclient).DownloadString('https://raw.githubusercontent.com/appveyor/ci/master/scripts/install-nuget-3-3-0.ps1'))
    

    I think you should report about that issue to NuGet team.

  2. 2 Posted by kneumei on 13 Apr, 2016 08:04 PM

    kneumei's Avatar

    This fixed my problem. Thanks!

    Unsure why nuget 3.4 broke things, but your script fixed it.

  3. Support Staff 3 Posted by Feodor Fitsner on 13 Apr, 2016 08:23 PM

    Feodor Fitsner's Avatar

    Looks like there is some regression in nuget 3.4.2, but it's better to get aware about it sooner than later. I'd better report to NuGet about this issue to make sure it's fixed.

  4. 4 Posted by andrewarnott on 15 Apr, 2016 04:57 AM

    andrewarnott's Avatar

    It would be nice to not have these VMs include prerelease versions of nuget.exe by default. I was broken by this too. I filed a bug against NuGet:
    https://github.com/NuGet/Home/issues/2553

    But this was only one of two issues. This one is blocking me. The other one I've already worked around.

    I specify the VM in my appveyor.yml to get reproducible builds. Suddenly getting a prerelease nuget.exe is unexpected.

  5. Support Staff 5 Posted by Feodor Fitsner on 15 Apr, 2016 05:03 AM

    Feodor Fitsner's Avatar

    Thanks for reporting that. We'll redeploy images with nuget 3.3 later this week.

  6. 6 Posted by andrewarnott on 15 Apr, 2016 05:49 AM

    andrewarnott's Avatar

    Thanks. Your workaround ps1 script worked for me, BTW.

  7. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:05 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac