Project refuses to build as release

richard's Avatar


25 Jun, 2014 12:36 AM

I'm having an issue with richardszalay/mockhttp whereby I can't seem to get it to build the solution as Release.

I have:
* Updated all projects to default to Release if $(Configuration) is not defined * Explicitly specified the configuration as "Release" and the solution filename in the "Build" tab of the Appveyor project

No matter what I do, Appveyor never passes in a Configuration to the msbuild command line and the solution always outputs 'Building solution configuration "Debug|Any CPU".'

Any help would be appreciated.


  1. Support Staff 1 Posted by Feodor Fitsner on 25 Jun, 2014 12:46 AM

    Feodor Fitsner's Avatar

    Hi Richard,

    It passes $(configuration) through environment variable when it's set on Build tab of project settings. If the property is not defined on msbuild command line then msbuild is looking for environment variable with the same name first.

  2. 2 Posted by richard on 25 Jun, 2014 01:18 AM

    richard's Avatar

    Hi Feodor,

    That sounds logical, but it doesn't seem to apply in practise:

    a) I have explicitly specified a Configuration in Appveyor Settings, so I would expect it to be explicitly passed to msbuild

    b) If it only sets an environment variable, it should be picked up by my solution (as you say), but it's not.

    The project in question is public. Can you take a look?


  3. Support Staff 3 Posted by Feodor Fitsner on 25 Jun, 2014 01:23 AM

    Feodor Fitsner's Avatar

    I see. You should add "configuration" into appveyor.yml, UI setting is ignored when yml is used.

    - Feodor

  4. 4 Posted by richard on 25 Jun, 2014 01:28 AM

    richard's Avatar

    That would explain a lot. Thanks!

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:45 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac