"Error pushing artifact: The operation has timed out" when calling appveyor PushArtifact

Kirill Müller's Avatar

Kirill Müller

15 Aug, 2014 12:00 AM

I'm trying to manually deploy artifacts to AppVeyor using the following command:

appveyor PushArtifact .\fakepackage.Rcheck\tests\test-all.Rout

I keep getting the error message

"Error pushing artifact: The operation has timed out"

and no artifacts appear for the build. What am I doing wrong? Thanks! (The project is open-source, all configuration is in the .yml.)

  1. Support Staff 1 Posted by Feodor Fitsner on 15 Aug, 2014 12:14 AM

    Feodor Fitsner's Avatar

    What is the size of that file? Does it exist? is it sporadic error?

    I've tested pushing an existing small file using the same command (https://ci.appveyor.com/project/appvyr/appveyor-bot-0904-0540/build...) as well as pushing a newly created empty file (https://ci.appveyor.com/project/appvyr/appveyor-bot-0904-0540/build...).

  2. 2 Posted by Kirill Müller on 15 Aug, 2014 06:13 AM

    Kirill Müller's Avatar

    The file exists, it's in the kilobytes, the error persists.

    Thanks for testing, but I haven't found this project on GitHub and hence cannot see what's different. I'll try to replicate this in an empty .yml project.

  3. 3 Posted by Kirill Müller on 15 Aug, 2014 06:51 AM

    Kirill Müller's Avatar

    I think I can replicate the problem: https://ci.appveyor.com/project/krlmlr/appveyor-artifact-test/build... . The project is on GitHub, I'm using the following .yml (not strictly minimal, but small enough I hope):

      ps: |
            $ErrorActionPreference = "Stop"
      - ps: New-Item .\new_empty_file.txt -type file
      - ps: Write-Host "build_script" -ForegroundColor Magenta
      - ps: Write-Host "test_script" -ForegroundColor Magenta
      - appveyor PushArtifact .\new_empty_file.txt
  4. Support Staff 4 Posted by Feodor Fitsner on 15 Aug, 2014 07:04 AM

    Feodor Fitsner's Avatar

    So the problem is in pushing a 0 file?

  5. 5 Posted by Kirill Müller on 15 Aug, 2014 08:10 AM

    Kirill Müller's Avatar

    No, it also happens with a non-empty file: https://ci.appveyor.com/project/krlmlr/appveyor-artifact-test/build... . Two timestamps are printed before and after the push attempt, the timeout is around two minutes.

  6. Support Staff 6 Posted by Feodor Fitsner on 15 Aug, 2014 06:18 PM

    Feodor Fitsner's Avatar

    Sure, will look into that. Thanks for the test project.

  7. Support Staff 7 Posted by Feodor Fitsner on 16 Aug, 2014 04:05 AM

    Feodor Fitsner's Avatar

    I've tried everything. I still don't know why, but there is something wrong with Get-Date in init section.

    Remove Get-Date and everything works: https://ci.appveyor.com/project/appvyr/appveyor-artifact-test/build...

    Put it back and it timeouts all calls to Agent API: https://ci.appveyor.com/project/appvyr/appveyor-artifact-test/build...

  8. 8 Posted by tomasz on 26 Nov, 2014 11:07 AM

    tomasz's Avatar


    I'm now having a similar problem in one of my projects. See log here.

    Here's my appveyor.yml is simple as 123

      - restore_packages.bat
    configuration: Release
      - nuget pack JsonLd.Entities.nuspec -Version %APPVEYOR_BUILD_VERSION%
      - appveyor PushArtifact JsonLd.Entities.%APPVEYOR_BUILD_VERSION%.nupkg


  9. Support Staff 9 Posted by Feodor Fitsner on 26 Nov, 2014 02:39 PM

    Feodor Fitsner's Avatar

    Will take a look.


  10. Support Staff 10 Posted by Feodor Fitsner on 27 Nov, 2014 05:44 AM

    Feodor Fitsner's Avatar

    It's been fixed. Give it another try and let me know how it goes.

  11. 11 Posted by tomasz on 27 Nov, 2014 07:11 AM

    tomasz's Avatar

    Now I simply got Error pushing artifact: The operation has timed out

  12. Support Staff 12 Posted by Feodor Fitsner on 27 Nov, 2014 07:27 AM

    Feodor Fitsner's Avatar

    OK, try using PS to upload artifact:

      - nuget pack JsonLd.Entities.nuspec -Version %APPVEYOR_BUILD_VERSION%
      - ps: Push-AppveyorArtifact "JsonLd.Entities.$($env:APPVEYOR_BUILD_VERSION).nupkg"
  13. 13 Posted by tomasz on 27 Nov, 2014 11:44 AM

    tomasz's Avatar

    PowerShell worked.

  14. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:50 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac