Tryng to use wild card on artifacts

daniel.blando's Avatar


26 Aug, 2014 10:34 PM

I have a project with some nuget packages, but i want to deploy only one of them.

In my file .yml I configured the artifacts configuration as:
  - path: Vtex.CacheCow.*.nupkg
    name: nuget

It has the name of the nuget package that i want and a wild card to the version number

And at deploy tag I am referencing as:
  - provider: Environment
    name: myget
    artifact: nuget
      release_tag: true

But when I build my project it still create and deploy all nuget artifacts.

  1. Support Staff 1 Posted by Feodor Fitsner on 27 Aug, 2014 03:10 PM

    Feodor Fitsner's Avatar

    You should specify "artifact" on Environment settings screen, not in deployment.

    What artifacts do you get on Artifacts tab of a build?


  2. 2 Posted by daniel.blando on 27 Aug, 2014 07:49 PM

    daniel.blando's Avatar

        I now understanding my error. I taught this artifact would temporaly overwritte the settings. I should have differents envirnmoents for this purpose.
       I have all the artifacts of the project in the artifacts tab. This could fix my problem too, trying to eliminate nuspec and creating only the nupkg that i want.


  3. daniel.blando closed this discussion on 03 Sep, 2014 03:11 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac