NuGet feed for project

Tim Jones's Avatar

Tim Jones

12 Sep, 2014 02:52 PM

I think I've messed up something to do with my NuGet project feed, but I'm not sure how to fix it.

The project is:

And the NuGet project feed is:

If I navigate to, I can see the packages listed

But, the problem is that NuGet in VS (or nuget.exe) doesn't find any packages. I've used Fiddler to have a look at the HTTP requests, and I can see that the Search call doesn't find any packages.

I previously had the Gemini project building newer versions of those NuGet packages. I've since deleted the project, and re-added it, in case that helped, but it didn't.

  1. 1 Posted by Tim Jones on 12 Sep, 2014 02:53 PM

    Tim Jones's Avatar

    I'm wondering if it's related to this:

    When you delete a project in AppVeyor its corresponding NuGet feed is deleted, however all NuGet packages from that feed remain published in account feed.

    from here:

  2. Support Staff 2 Posted by Feodor Fitsner on 12 Sep, 2014 08:19 PM

    Feodor Fitsner's Avatar

    Yeah, if you delete the project and then re-create it again its corresponding NuGet feed is also re-created, however packages from it remain in account feed.

    I think I've fixed that feed, you can try these commands:

    nuget list -source
    nuget list -source -prerelease

    I'm going to reproduce this issue locally. You say you just deleted project, right?

  3. 3 Posted by Tim Jones on 13 Sep, 2014 06:15 AM

    Tim Jones's Avatar

    Awesome, the project feed works now, thank you.

    Here's the sequence of events:

    • The {version} was set to 1.0.{build}
    • I did a build, which created NuGet packages with versions like 1.0.0
    • I changed {version} to something like 0.5.0.{build}
    • I did a build
    • Because the new NuGet packages had an lower version than the older NuGet packages, they didn't show up in VS - only the older NuGet packages, with the higher version number, showed up (which makes sense)
    • So I deleted the project, thinking that would solve the problem
    • But when I re-created the project and did a build, I didn't get anything in the NuGet project feed
  4. 4 Posted by Tim Jones on 13 Sep, 2014 06:47 AM

    Tim Jones's Avatar

    Sorry, it's still not quite working. I did another build (0.6.0-ci6), but VS still shows 0.6.0-ci5.

    I've also just changed the build format to 0.6.0-ci1000, which is lexographically lower than, say, 0.6.0-ci2, so should I delete the project and re-create it, to get rid of the existing artifacts?

    Thanks for your time looking at this.

  5. Support Staff 5 Posted by Feodor Fitsner on 14 Sep, 2014 12:08 AM

    Feodor Fitsner's Avatar

    OK, will be investigating further.


  6. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:48 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac