Deploying to GitHub releases

José Simões's Avatar

José Simões

08 May, 2017 08:53 AM


Trying to deploy to GitHub releases on this project:
I can see the artefact generated (it's a Visual Studio extension whose file name uses '.visx' as extension).
And I can see the draft being created.
Now I have two issues: 1) the artefact is not added to the draft release. 2) if I go into the artifacts tab and download it, the downloaded file shows as a '.zip' file.

The deployment part is setup as:


- provider: GitHub
  tag: v$(appveyor_build_version)
  release: nanoFramework VS2017 Extension v$(appveyor_build_version)
  description: add description here
    secure: XPPc2eTBV6X1Wp8cQIjJ/VEJW+UMrz9eYmxIUilw9tIF869lk7IYpBVSvb68EvPyjUOjzkI9iCRW0a+t4u83z23MOeA/c3lbviZpnqmoMoE=
  artifact: /.*\.visx/
  draft: true
  prerelease: true
  force_update: false

  1. 1 Posted by Ilya Finkelshte... on 08 May, 2017 08:21 PM

    Ilya Finkelshteyn's Avatar

    Cold you please send us artifacts: part of your configuration (or better the whole configuration in YAML)?

  2. 2 Posted by José Simões on 09 May, 2017 08:53 AM

    José Simões's Avatar

    Here’s the yaml:

    version: 0.1.{build}
      do_not_increment_build_number: true
      - master
    image: Visual Studio 2017
    configuration: Debug
    clone_depth: 1
    - cmd: git submodule update --init --recursive
    - ps: >-
        msbuild source\Tools.MetaDataProcessor\nanoFramework.Tools.MetaDataProcessor.sln /p:Configuration=Release /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"

        nuget restore source\Tools.BuildTasks\Tools.MSBuildSystem.sln

       msbuild source\Tools.BuildTasks\Tools.MSBuildSystem.sln /p:Configuration=Release /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"

        nuget restore source\nanoFramework.Tools.VisualStudio.AppVeyorBuild.sln

        msbuild source\nanoFramework.Tools.VisualStudio.AppVeyorBuild.sln /p:Configuration=Release /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"
    - path: '**\bin\Release\*MSBuildSystem*.nupkg'
      name: MSBuild System Nuget Package
    - path: '**\*.vsix'
      name: VS extension
    - provider: NuGet
        secure: NSRDXbS8tmzOy4wStGuO3yQMKI8Sk10vF8iQtz9ZDXEnHfwnuDdnXbr/Kno3MMvY
      skip_symbols: true
    - provider: GitHub
      tag: v$(appveyor_build_version)
      release: nanoFramework VS2017 Extension v$(appveyor_build_version)
      description: add description here
        secure: DNixoFFE+pGlwyhj7McfZoln42vOmj0iY1iNV9zXEr3y0NpXlOIgL8k5ehzlFM1S
      artifact: /.*\.visx/
      draft: true
      prerelease: true
      force_update: false

  3. 3 Posted by Ilya Finkelshte... on 10 May, 2017 05:40 PM

    Ilya Finkelshteyn's Avatar

    Sorry late reply and for back and forth, but I see that your artifact has vsix extension, not zip...
    Also I see that artifact is added to GitHub release, also see attached picture.

    I probably misunderstand the problem, if yes, please elaborate...


  4. 4 Posted by José Simões on 10 May, 2017 06:08 PM

    José Simões's Avatar

    I know that it has a vsix extension, the fact is that when I try to download it (by clicking on the URL) it’s downloaded as a ZIP file.
    (have you tried that yourself?)

    As for the release that you are seeing there on the image, I edited it manually to include the artefact there….. no surprise it’s there.
    I have a few others in draft that have no artefact attached.

  5. 5 Posted by Ilya Finkelshte... on 10 May, 2017 07:24 PM

    Ilya Finkelshteyn's Avatar

    Yes I tried that, see pic. Please try to use artifact deployment name in GitHub deployment provider settings, e.g. artifact: VS extension.

  6. 6 Posted by José Simões on 11 May, 2017 04:00 PM

    José Simões's Avatar

    To let you know that after:

    1) Renaming the artifact so it doesn’t have spaces

    2) Using the artefact name instead of the expression (as you suggested)

    I now have a draft deployment on GitHub that includes the artefact file.

    So I would say that there should be an underlying issue with the artifact naming handling. Or it can’t allow names with spaces or, if those are allowed, then something seems to be broken about that…

    De: Ilya Finkelshteyn [mailto:[email blocked]]
    Enviada: 10 de maio de 2017 20:24
    Para: José Simões <[email blocked]>
    Assunto: Re: Deploying to GitHub releases [Questions #3823]

  7. 7 Posted by Ilya Finkelshte... on 11 May, 2017 05:35 PM

    Ilya Finkelshteyn's Avatar

    Right, thank you for catching this! Filed this issue

  8. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:17 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac