Use AppVeyor to deploy changes to Octopress Blog

gep13's Avatar


03 Sep, 2014 06:53 AM


I have just started using Octopress for my blog, and I would like to use AppVeyor to support the deployment of the generated static files to my Github Repository.

I have found a blog post which describes how this can be done using a standalone instance of TeamCity:

And I am wondering if this is possible using AppVeyor?

Would it be possible for you to provide some guidance on how to get started with this? I created a basic build configuration in AppVeyor just now, and did the first step in the blog post which was to execute "bundle install", however, this resulted in an error:

Any ideas how to proceed?



  1. Support Staff 1 Posted by Feodor Fitsner on 03 Sep, 2014 09:23 PM

    Feodor Fitsner's Avatar

    It fails while installing rdiscount gem in extconfig.rb. It expects int to be 2 bytes in size:

    def sized_int(size, types)
      types.find { |type| check_sizeof(type) == 4 } ||
        abort("no int with size #{size}")
    DWORD = sized_int(4, ["unsigned long", "unsigned int"])
    WORD =  sized_int(2, ["unsigned int", "unsigned short"])
    BYTE = "unsigned char"
    VERSION ='VERSION').strip

    Maybe it's solely Windows problem...

  2. 2 Posted by gep13 on 03 Sep, 2014 09:32 PM

    gep13's Avatar


    Thanks for getting back to me.

    I do my development work in a Windows Machine, Windows 8, and I can confirm that running bundle install works fine there.


    Sent from my Windows Phone

  3. Support Staff 3 Posted by Feodor Fitsner on 03 Sep, 2014 09:39 PM

    Feodor Fitsner's Avatar

    Right, I've tried on my laptop and it worked too. Need to investigate further.

  4. 4 Posted by gep13 on 03 Sep, 2014 09:48 PM

    gep13's Avatar

    Thank you! Appreciate it!

    Sent from my Windows Phone

  5. Support Staff 5 Posted by Feodor Fitsner on 04 Sep, 2014 01:38 AM

    Feodor Fitsner's Avatar

    OK, found the problem! You will never ever believe what was the problem: :)

    "Application Experience" service was indeed disabled on AV build workers as "unnecessary". This is the case where it's needed though I'm not sure what's going on.

    I'm deploying updated build worker image later today.

    This is the results for your Gemfile:

  6. Support Staff 6 Posted by Feodor Fitsner on 04 Sep, 2014 04:03 AM

    Feodor Fitsner's Avatar

    New image is online. rdiscount gem installation should be fine now.

  7. 7 Posted by gep13 on 04 Sep, 2014 06:05 AM

    gep13's Avatar

    Thank you so much for looking into this! I am away to give this a try just now!

  8. gep13 closed this discussion on 04 Sep, 2014 06:19 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac