Build is failing with no error message

raghu's Avatar

raghu

27 Apr, 2018 03:16 PM

Build is failing with below error
Command executed with exception: ignore@2.2.19: several bugs fixed in v3.2.1

not much of reason is found with error, also attached the log file from the appveyor, any input regarding this greatly appreciated

  1. Support Staff 1 Posted by Owen McDonnell on 27 Apr, 2018 05:49 PM

    Owen McDonnell's Avatar

    Can you please provide log and/or configuration yaml.

  2. 2 Posted by raghu on 27 Apr, 2018 05:53 PM

    raghu's Avatar

    attached the log file

  3. Support Staff 3 Posted by Ilya Finkelshte... on 27 Apr, 2018 05:59 PM

    Ilya Finkelshteyn's Avatar

    Thank you. We also need build configuration in YAML format (use Export YAML menu if you use UI). Also did it work OK before? If yes, please send a links to last good and first bad build.

  4. Support Staff 4 Posted by Owen McDonnell on 27 Apr, 2018 06:01 PM

    Owen McDonnell's Avatar

    Thanks Raghu,
    Sorry, I didn’t notice that you already sent the log by email when I read the forum post.

    Are you able to provide your yaml configuration file? If you use UI for configuration you can go to ‘Export YAML’ tab of project settings and see it there.
    Also, when was the last successful build?

    Owen.

  5. 5 Posted by raghu on 27 Apr, 2018 06:08 PM

    raghu's Avatar

    attached the successful log file and attached the yml file

  6. Support Staff 6 Posted by Owen McDonnell on 27 Apr, 2018 10:53 PM

    Owen McDonnell's Avatar

    Thanks, do you have a successful build which makes use of caching (see line 45 of your appveyor.yml file)? In the successful build log from 00:00:32 on nuget is restoring packages whereas in the failed log the cache has already been restored.

    Owen.

  7. 7 Posted by raghu on 27 Apr, 2018 11:00 PM

    raghu's Avatar

    i dont have a successful build

  8. Support Staff 8 Posted by Owen McDonnell on 27 Apr, 2018 11:04 PM

    Owen McDonnell's Avatar

    So you recently added caching to your build and then started getting build errors?

  9. 9 Posted by raghu on 27 Apr, 2018 11:11 PM

    raghu's Avatar

    caching is not new, it is exists even before too, cache already populated you might are seeing because i retried it multiple times, log is from that

  10. Support Staff 10 Posted by Owen McDonnell on 27 Apr, 2018 11:26 PM

    Owen McDonnell's Avatar

    Can you disable the cache and see if the build is successful? That way we can rule out if it is a caching issue.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac